Welcome to Vortx Community Forum, where you can ask questions and receive answers from the staff at Vortx and other members of the community.

If you had a user account on our previous forums website, you will need to register a new account here.

Learn more about...

AspDotNetStorefront
DotFeed

9.4 mobile site showing up in safari on a mac

Hello,

I've been upgrading a few aspdotnetstorefront site's in the past few weeks and have been getting complaints that the site looks different in Safari on a Mac.  After some screenshot sharing, I found out the site was defaulting to the mobile version for these people.  Does anyone have a fix for it OTHER THAN "just click the "go to desktop" link.
asked Oct 4, 2013 in MultiStore by brian (240 points)

2 Answers

0 votes
If you have access to your SQL table MobileDevice you could try removing those values that relate to Safari.

 

Not sure how this would affect iphone/Ipad though, it does seem to have its own value in there.
answered Oct 7, 2013 by Skriver (2,345 points)
Which ones relate to safari?
At a guess I'd say Iphone as it's their default browser that may somehow be forcing the desktop client into a mobile view. Strange though as I've never heard of this happening before.

If you don't use mobile versions of the site you could look at changing the app config mentioned here

http://manual.aspdotnetstorefront.com/p-1419-how-do-i-disable-the-built-in-mobile-skin.aspx

Maybe someone at Vortx can answer which value controls Safari. Good luck!
+2 votes

I had this same issue.  The fix from the tech support folks at aspdotnetstorefront was to remove 'tosh' from the AppConfig->Mobile.ShortUserAgentList

answered Dec 31, 2013 by june (545 points)
edited Jan 6, 2014 by june

I think this edit should be made to the AppConfig.Mobile.ShortUserAgentList

yes - ShortUserAgentList. Answer edited. Thanks for the correction!

...