Welcome to Vortx Community Forum, where you can ask questions and receive answers from the staff at Vortx and other members of the community.

If you had a user account on our previous forums website, you will need to register a new account here.

Learn more about...

AspDotNetStorefront
DotFeed

Admin menus not all visible in 9.4.0.0

The dropdown menus in the admin are not all showing up. I mouse over the Configuration menu  and you can see what has happened by looking at the gif file (either attached or below). I am using Firefox 24 on Windows XP but this also happens on Google Chrome. It happens on all the other dropdown menus as well - really only happens when a menu item has child items - one can see the blank areas with the arrows to the right.

Also, there is a lot of extra "stuff" on the other links like "admin.default.RunConfigurationWizard" - why is the "admin.default" there? Again, please refer to the gif file.

A couple of other things: a) this is on my localhost and b) I did change the name of the "Admin" directory as this is (or was) a recommended practice and worked well on my 8.0.1.2 version.

 

asked Oct 24, 2013 in MultiStore by walkinwillie (120 points)
Got the string resources loaded so that is a non-issue. Still have the mysterious disappearing child menus though.

BTW, thanks for your first reply - very much appreciated.

3 Answers

0 votes
Hmm, does it happen also in IE?  BTW, based on the lower left of your screenshot, it looks like you didn't import your String Resources? Try doing that too via the COntent String Resources menu...
answered Oct 25, 2013 by jsimacek (6,825 points)
Yes, the same thing - child menus not showing up - happens in IE8 (latest version I have as I try to avoid IE). Wonder if it is a style sheet bug.

Also, I have tried importing the String Resources several times and each time, it looks like it is doing fine with a big long list of the strings and its more understandable, intuitive values. However, it doesn't appear to work - even reset the cache.

I am doing the string importing from server - should I do it from my PC?
Hmm, yes do it from your PC to make sure you are using the latest for your cart release.

Yeah, IE8 is not a good release to stay on and probably would be ok if you tried on IE9 or IE10?
Well, IE 9 and IE10 might work for showing the child menus but it doesn't work on the latest FireFox and Google Chrome so I don't think it is a browser issue.

What is happening is that the background for the menu item isn't showing up. If I go to the Products menu, it isn't so bad as the white font shows up on the blue background.

But if I go to the Configuration menu where the dropdown is over a white background, then the menu's white font doesn't show up except for the small parts that are over the black font on the background. That's why I believe it might be a stylesheet issue - i.e. it didn't work on three different browsers, two of which are the latest versions.

Thanks again for your help!
Hmm, I just tested on my stock MS9400 in FF (latest) and it's ok...(showing all menus fine)

Did you by any chance upgrade from previous version? Cna you try a "clean" install of admin where you remove all files in /admin and just put in the new release files?
When I upload the localhost site to my Windows 2008 cloud, it might work then. It might be that Windows XP is the problem - or in particular IIS 5.1
I did do an upgrade but I completely wiped the Admin folder as per the instructions so that all the files in the Admin folder are new. I did look at the css and everything seems OK. This isn't a huge deal but wish it would work better.
0 votes
We had this problem on one upgrade while a site was in staging and could never find how to fix the issue. When it was time to move to production, instead of moving over the broken staging site we just did a fresh upgrade in the production environment, just make sure you take a backup of both your file system and database if you're going to try this route.
answered Oct 30, 2013 by cbright (400 points)
0 votes
Yes, I have come accross this issue before.

1) In IIS, ensure your Application Pool is running the correct .NET framework version.

2) You may need to install ASP.NET 3.5 SP1.

In an effort to help others who may come accross the same issue, make sure to select the answer that solved your issue.

Sincerely,
Robert
answered Oct 30, 2013 by Robert (3,440 points)
...