Welcome to Vortx Community Forum, where you can ask questions and receive answers from the staff at Vortx and other members of the community.

If you had a user account on our previous forums website, you will need to register a new account here.

Learn more about...


Why am I getting an XmlPackage not found error for an XmlPackage that exists?

While I get the upgrade to v10 working, we're still on our v9.4.2 store, and it's been giving me a most inexplicable error. When I view the store as an anonymous user, everything works fine. But once I log on with my admin account, I get a server error:

Error in XmlPackage(.Load), Package=[rev.categories.xml.config], Msg=[The XmlPackage file could not be found. The search tree is: App_Templates/skin_{activeskinid}/XmlPackages and then the /XmlPackages folders in your web site. Please make sure that you have FTP'd the file up to the server!]

...But that XmlPackage definitely exists. It's right there in /App_Templates/Skin_1/XmlPackages. 

It traces the error back to a line in /App_Templates/Skin_1/template.master that I wrote:

Line 167:	<asp:Literal ID="CategoriesSide" runat="server" Text='<%$ Tokens:XMLPACKAGE, rev.categories.xml.config%>' />

Curiously, I haven't been able to reproduce this error on other people's computers or under other people's accounts. Though I am nervous that other people are seeing it when they log on, somewhere in Customerland. Also, I can view the admin site fine, presumably because it never calls template.master.

Anyone have any idea what could possibly be going on here?!


asked Jul 21, 2016 in MultiStore by Nathanael (425 points)

P.S. I already tried adding a space into the token call where one seemed to be missing —

[...] rev.categories.xml.config %>' />

— and that didn't solve it.

1 Answer

0 votes
Best answer
Check your Customer record in the DB and the Profile rows tied to it by CustomerID.  I bet you've got a non-1 value in there somewhere, so ASPDNSF is looking for that XML package in a different skin for your account.
answered Jul 21, 2016 by Vortx ScottS (13,500 points)
selected Jul 21, 2016 by Nathanael

Man, that's weird. I got it fixed. Ran this query (not sure if it was necessary): 

UPDATE Customer SET SkinID = 1 WHERE CustomerID = [my ID];

It still gave me a server error, so then I tried visiting our homepage with ?skinid=1 at the end. It loaded the homepage, but with a message added to the homepage in a place I'd never seen at the top of the page:

You are previewing the Skin_503268019 skin. Click the button to the right to end the preview.

I clicked the button after it with the text "End Preview" and it got itself sorted out. Something to do with having visited our v10 dev site maybe? Who knows. Anyhow, thanks for getting me on the right track.