Welcome to Vortx Community Forum, where you can ask questions and receive answers from the staff at Vortx and other members of the community.

If you had a user account on our previous forums website, you will need to register a new account here.

Learn more about...

AspDotNetStorefront
DotFeed

New v10 test site with .Net v4.6.1590 installed stack trace problem

I'm getting the following stack trace on trying to start the site up. This doesn't occur on localhost, and the site is a test URL so is not possible to debug because I don't want to install VS on the server. Anyone got any ideas, please?

Value cannot be null.
Parameter name: routeCollection

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

Exception Details: System.ArgumentNullException: Value cannot be null.
Parameter name: routeCollection

Source Error: 

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace: 


[ArgumentNullException: Value cannot be null.
Parameter name: routeCollection]
   System.Web.Mvc.UrlHelper.GenerateUrl(String routeName, String actionName, String controllerName, RouteValueDictionary routeValues, RouteCollection routeCollection, RequestContext requestContext, Boolean includeImplicitMvcValues) +291
   System.Web.Mvc.UrlHelper.Action(String actionName, String controllerName) +40
   AspDotNetStorefront.Application.MvcApplication.Owin_Start(IAppBuilder app) +238

[TargetInvocationException: Exception has been thrown by the target of an invocation.]
   System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor) +0
   System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments) +128
   System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture) +146
   Owin.Loader.<>c__DisplayClass12.<MakeDelegate>b__b(IAppBuilder builder) +93
   Owin.Loader.<>c__DisplayClass1.<LoadImplementation>b__0(IAppBuilder builder) +209
   Microsoft.Owin.Host.SystemWeb.OwinAppContext.Initialize(Action`1 startup) +843
   Microsoft.Owin.Host.SystemWeb.OwinBuilder.Build(Action`1 startup) +51
   Microsoft.Owin.Host.SystemWeb.OwinHttpModule.InitializeBlueprint() +101
   System.Threading.LazyInitializer.EnsureInitializedCore(T& target, Boolean& initialized, Object& syncLock, Func`1 valueFactory) +137
   Microsoft.Owin.Host.SystemWeb.OwinHttpModule.Init(HttpApplication context) +172
   System.Web.HttpApplication.InitModulesCommon() +201
   System.Web.HttpApplication.InitInternal(HttpContext context, HttpApplicationState state, MethodInfo[] handlers) +1069
   System.Web.HttpApplicationFactory.GetNormalApplicationInstance(HttpContext context) +382
   System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +433

Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.6.1590.0

 

asked Nov 3, 2016 in MultiStore by esedirect (405 points)

1 Answer

+1 vote

Hmm, do you have URL Rewrite IIS module installed? Also, you might want to check the permissions on the server?

Thank you,
Jan

Compunix, LLC (Phoenix, AZ)
AspDotNetStorefront Development Partner and Reseller since 2005
------------------------------------------------------------------------------------------------------
 AspDotNetStorefront add-ons and plugins : http://www.ecommercecartmods.com
  * Searching Filtering, Single Signons, Reviews Ratings, Reports, Integrations
 Complete Automotive Solution : http://www.autopartsshoppingcart.com
  * Auto + Aftermarket Parts solution
 Unlimited Custom Development : http://www.compunix.us/t-unlimited-custom-development.aspx
  * Unlimited with Quick turn-arounds!
------------------------------------------------------------------------------------------------------

 

answered Nov 4, 2016 by jsimacek (6,765 points)
Thanks Jan. We do have IIS Rewrite 2 installed on the server, so I removed that module from the website, but still got the error. Then going with your second suggestion on permissions, I looked over the AppPool user and db user, made some adjustments and hey presto!

 

So thanks.
...