Hopefully it will be a simple one... I may have done it before but probably it was so many time ago that I really cannot recall... so please help!


I created a small configuration table where I am saving and pulling from some messages to splash on the screen. The messages have a few embed simple formatting HTML (such as line breaks) and so the xml.config file is displaying the HTML instead to parse it. How can I fix it?

Example, this...

<xsl:value-of select="/root/Messages/MessagesRow/ThankYou"/>

Should display something like...

Thank you very much.
Looking forward to see you again!

Instead it's displaying...

Thank you very much.<br/>Looking forward to see you again!

Any idea? Thanks!


closed with the note: This is solved and the answer was tagged as a best one!
in MultiStore by (1.2k points)
closed by

1 Answer

+1 vote
Best answer
The disable-output-escaping="yes" attribute missing from your xsl:value-of is the issue.
by (5k points)
selected by


Thank you for the heads up.

I have posted before that it didn't work because I was almost totally sure that I have used the disable-output-escaping="yes" attribute and it didn't work...

Anyway, just in case I returned to my code and put the attribute back and IT WORKED. I don't know what hapenned before. Perhaps I am getting too old for this sh*t. LoL.

Thank you very much!


We are talking about changing <xsl:value-of select="/root/Messages/MessagesRow/ThankYou"/> to <xsl:value-of select="/root/Messages/MessagesRow/ThankYou" disable-output-escaping="yes" /> correct?

If so I need more context as to where the output is. Since it could be something after the xmlpackage transform causing the html escaping.

No worries mmcgeachy look above! You were right since the beggining! wink